Testnet Degradation - Indexer Full node down

Incident Report for dYdX V4 Testnet

Resolved

This incident has been resolved.
Posted Jun 14, 2025 - 03:40 UTC

Update

Indexer recovery ETA 2025-06-14 0400Z.
Posted Jun 14, 2025 - 00:03 UTC

Update

Testnet Indexer DB storage migration is complete.
Indexer recovery ETA 2025-06-14 0530Z.
Posted Jun 13, 2025 - 19:57 UTC

Update

Testnet Indexer full node has recovered.
Testnet Indexer archival process is still underway. 2TB DB storage is being buffed to accelerate backfill. Will update ETA when storage provisioning is complete and new higher throughput can be measured. Expect provisioning to complete by 2025-06-13 2100Z.
Posted Jun 13, 2025 - 18:45 UTC

Monitoring

Testnet Indexer full node has been restored and is catching up. ETA 2025-06-13 07:30Z
Testnet Indexer archival process is catching up at a slower and variable rate. ETA 2025-06-13 16:00Z to 2025-06-15 02:00Z
Posted Jun 12, 2025 - 23:16 UTC

Investigating

dYdX Testnet Indexer full node is currently not functional resulting in the Frontend not being fully functional
Posted Jun 07, 2025 - 13:20 UTC
This incident affected: v4.testnet.dydx.exchange.